RSIGuard Technical Note

Problem:

RSIGuard 4.0 crashes when displaying a stretch video during a break or gives an MCI error. In some cases, the mouse and keyboard might be unresponsive, requiring a reboot.

Cause:

There are two categories of problem that may be occurring.

(A) MainConcept, a video software company, produces a "codec" (a piece of software required for a computer to convert a video file into images on the screen) that they supply to many other software manufacturers (e.g. muvee, Pinnacle, and others) for use in their applications (e.g. muvee AutoProducer). In late 2004 and early 2005, they shipped a codec with a serious bug that prevented Windows built in MCI multimedia system from playing any MPEG file. When a user attempts to play an MPEG (e.g. with Microsoft PowerPoint, MPlay32, or RSIGuard) the codec crashes the application.

(B) The other problem is that your computer may not have proper MCI drivers installed. For example, the MCI drivers are not standard on some Windows Server configurations.

Solution:

There are several approaches to solving these problems.

1) To start, try the solution offered on our FAQ at http://www.rsiguard.com/usefaq.htm#Video

2) To solve problem (A), acquire an update for the offending video software from the software manufacturer. At present, companies like muvee and MainConcept have released fixes to their software that prevent their codec from interfering with other applications. Uninstalling the offending software will also resolve the problem. You may not even know the software is there since some computer manufacturers pre-install software on their computers.

3) To solve problem (A) or (B), Remedy Interactive provides alternate videos that use the WMV format instead of MPEG. These videos require that you have installed Windows Media Player 9 or later.

==> Click here to download the Windows Media Video (WMV) format stretch videos.

 

If you need further assistance, please contact RSIGuard support.